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Safety Information

Regulatory Compliance

The CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board is intended for use as a evaluation
platform for hardware or software in a laboratory environment. The board is an open system design,
which does not include a shielded enclosure. This may cause interference to other electrical or
electronic devices in close proximity. In a domestic environment, this product may cause radio
interference. In such cases, you may be required to take adequate preventive measures. In addition,
this board should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default
settings may affect its performance and cause interference with other apparatus in the immediate
vicinity. If such interference is detected, suitable mitigating measures should be taken.

The CY8CKIT-148-COIL Inductive Sensing Coil Breakout
Board, as shipped from the factory, has been verified to meet
with requirements of CE as a Class A product.

End-of-Life/Product Recycling

This kit has an end-of life five years from the date of manufacture
mentioned on the back of the box. Contact your nearest recycler for
discarding the kit.
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1. Introduction

The CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board is designed as an easy-to-use and
inexpensive evaluation platform. The Kit along with the CY8CKIT-148 PSoC® 4700S Inductive
Sensing Evaluation Kit (EVK) delivers a low cost and complete system solution for embedded
applications of Inductive sensing. 

While the CY8CKIT-148 EVK can be used stand-alone, this kit offers additional sensor patterns for
evaluating Inductive Sensing Technology with PSoC 4700S device. 

Download the kit guide of the CY8CKIT-148 PSoC® 4700S Inductive Sensing Evaluation Kit from
the webpage for more details on the base board that is used in conjunction with this kit.

1.1 Kit Contents

CY8CKIT-148-COIL kit includes the following:

■ Inductive Sensing Breakout Board 

■ Metal Target (Rotary Target)

■ FPC cable 

The Quick Start Guide is printed on the kit package.

Figure 1-1.  CY8CKIT-148-COIL Kit Contents

www.cypress.com/cy8ckit-148
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1.2 Getting started with the Kit

To start with the CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board, follow the steps below:

■ Check the kit contents as described in Kit Contents on page 5.

■ Download the hardware files from the kit webpage.

■ The breakout board has three metal targets as shown in Figure 1-2.

Figure 1-2.  Three metal targets on the CY8CKIT-148-COIL board 

www.cypress.com/cy8ckit-148-coil
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■ Break METAL TARGET 1 and METAL TARGET 3 as shown in Figure 1-3.

Figure 1-3.  METAL TARGET 1 and METAL TARGET 3 on the CY8CKIT-148-COIL board 

Figure 1-4.  CY8CKIT-148-COIL board after removal of METAL TARGET 1 and METAL TARGET 3
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■ Place the breakout board flat on the edge of a stable surface with METAL TARGET 2 hanging 
over the edge. Holding the breakout board firmly, apply downward pressure to METAL TARGET 2 
to break the target away.
This is an optional step. User can leave METAL TARGET 2 attached if they are not going to use it 
for one of the sliders.

Figure 1-5.  Procedure to break the METAL TARGET 2 
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Figure 1-6.  Breakout regions that may get affected because of improper breaking procedure 

■ The following on-board sensors are not connected to any of the FPC connectors. 

❐ BTN/PROX SENSOR (SQ7, SQ8)

❐ BTN/PROX SENSOR (CR1, CR2)

❐ BTN SENSOR (CR3, CR4)

If you want to evaluate any of these sensors, you need to connect wires between the 
corresponding I/O header on the breakout board and the coil expansion connector (J4) on the 
CY8CKIT-148 kit. In addition to that you need to change some components on the CY8CKIT-148 
board. See Table A-2 on page 26 for connection details. 

■ There are two on-board FPC connectors. The remaining sensors below are connected to the 
FPC connectors and the headers both. 

❐ LINEAR ENCODER (LE1, LE2)

❐ ROTARY ENCODER (RE1, RE2)

❐ 6-SEGMENT SLIDER (SQ1 to SQ6)

These sensors are default connected to the FPC connector. If there is any requirement of 
connecting the sensors through the headers, you need to refer the same Table A-2 on page 26.

■ See the Kit Operation chapter on page 18 that describes the principle of inductive sense technol-
ogy. This chapter describes all the inductive sensor patterns present on this board.

■ See the Appendix chapter on page 24 to get header and connector details of the board, Kit Sche-
matics, and the bill of materials (BOM).

Improper Breaking 
procedure of the 
metal target will 
cause this area to 
break. The LINEAR 
ENCODER sensors 
will get disconnected 
from the FPC 
connector

METAL TARGET 2 can be difficult to break away from the breakout board. Carefully follow
the procedure described above.
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1.3 PSoC Creator

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces
revolutionary hardware and software co-design, powered by a library of pre-verified and pre-
characterized PSoC Components. With PSoC Creator, you can:

1. Drag and drop Components to build your hardware system design in the main design workspace.

2. Co-design your application firmware with the PSoC hardware.

3. Configure Components using configuration tools.

4. Explore the library of 100+ Components.

5. Review Component datasheets.

Figure 1-7.  PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains
and programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator. Visit the PSoC Creator Video Training
Page for video tutorials on learning and using PSoC Creator.

 

www.cypress.com/psoccreator
http://www.cypress.com/?rID=40547
http://www.cypress.com/?rID=40547
http://www.cypress.com/?rID=40547
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1.3.1 Installing PSoC 4700S Device in PSoC Creator

The steps below need to be followed in order to install PSoC 4700S device into PSoC Creator before
opening the code example workspace for the first time. These steps only need to be done once.

1. Run PSoC Creator 4.2.

2. Go to Tools > Find new devices in PSoC Creator. The Device Update Installer window will 
pop-up.

Figure 1-8.  Device Update Installer

3. Click on the Install Button.

4. Restart PSoC Creator. Note that this is an important step. The devices will only be available 
after PSoC Creator is restarted.

The devices should now be available in the device selector when you create a new project.

From the dropdown list, select PSoC 4700S.

Figure 1-9.  Device Selection 
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1.3.2 Installing the MagSense Component

The steps below need to be followed to install the latest version of the MagSense component before
opening the code example workspace for the first time. These steps only need to be done once.

1. To install the MagSense Component, Click Tools > Find new components. Figure 1-10 shows 
this step. 

Figure 1-10.  Tools Tab for finding New Components 

2. Select the MagSense Component and click Install Checked Components. This will install the 
MagSense Component in your software.

Note: You can skip this step if the MagSense Component is pre-installed in PSoC Creator.

Figure 1-11.  Component Installation 
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1.3.3 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are available from the
PSoC Creator Start Page, as shown in Figure 1-12 or from the menu File > Code Example....

Code examples can speed up your design process by starting you off with a complete design,
instead of a blank page. The code examples also show how PSoC Creator Components can be
used for various applications. Code examples and documentation are included, as shown in
Figure 1-13 on page 13.

From the Find Code Example dialog shown in Figure 1-13 on page 13, you can:

■ Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or PSoC 5LP, 
project name, or keyword.

■ Select from the list of examples offered based on the Filter Options.

■ Review the code example’s description (on the Documentation tab).

■ Review the code from the Sample Code tab. You can copy the code from this window and paste 
to your project, which can help speed up code development.

■ Create a new project (and a new workspace if needed) based on the selection. This can speed 
up your design process by starting you off with a complete, basic design. You can then adapt that 
design to your application.

Figure 1-12.  Code Examples in PSoC Creator

Figure 1-13.  Code Example Projects with Sample Code



CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board Kit Guide, Document Number: 002-26890 Rev. ** 14

Introduction

1.3.4 Kit Code Examples

You can access the installed kit code examples from the PSoC Creator Start Page. To access these
examples, expand Kits under Start; then, expand CY8CKIT-148 to see the code examples. You can
download CE225409-PSoC 4700S MagSense COIL for example projects that can be used with the
CY8CKIT-148 and CY8CKIT-148-COIL to implement custom applications.

1.3.5 PSoC Creator Help

Launch PSoC Creator and navigate to the following items:

■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 
the basics for developing PSoC Creator projects.

■ Simple Component Code Examples: Choose File > Code Example. These examples 
demonstrate how to configure and use PSoC Creator Components. To access examples related 
to a specific Component, right-click the Component in the schematic or in the Component 
Catalog. Select Find Code Example in the context menu that appears.

■ System Reference Guide: Choose Help > System Reference Guides. This guide lists and 
describes the system functions provided by PSoC Creator.

1.3.6 Component Datasheets

Right-click a Component and select Open Datasheet (see Figure 1-14).

Figure 1-14.  Opening Component Datasheet
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1.4 Additional Learning Resources

Cypress provides a wealth of data at www.cypress.com to help you select the right PSoC device for
your design, and to help you quickly and effectively integrate the device into your design. For a com-
prehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and PSoC 5LP.
The following is an abbreviated list for PSoC 4:

■ Overview: PSoC Portfolio and PSoC Roadmap.

■ Product Selectors: PSoC 4 Product Selector. In addition, PSoC Creator includes a device 
selection tool.

■ Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, 
PSoC 4200, PSoC 4100M, PSoC 4200M, PSoC 4200L, PSoC 4100S Plus and PSoC 4700S 
devices.

■ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the 
PSoC 4 and PSoC Analog Coprocessor family of devices.

■ Inductive Sensing Design Guide: Learn how to design inductive sensing applications with the 
PSoC 4 family of devices. 

■ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced. 
Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples 
webpage for a list of all available PSoC Creator code examples. To access code examples from 
within PSoC Creator, see PSoC Creator Code Examples on page 13.

■ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and 
registers in each PSoC 4 device family.

■ Development Kits:

❐ CY8CKIT-041, CY8CKIT-046, CY8CKIT-044, CY8CKIT-042, and CY8CKIT-040 are easy-to-
use and inexpensive development platforms. These kits include connectors for Arduino™ 
compatible shields and Digilent Pmod Peripheral Modules.

❐ CY8CKIT-043, CY8CKIT-049, CY8CKIT-145, CY8CKIT-146, and CY8CKIT-149 are very low-
cost prototyping platforms for sampling PSoC 4 devices.

❐ CY8CKIT-001 is a common development platform for all PSoC family devices.

❐ The MiniProg3 and MiniProg4 devices provide interface for flash programming and debug.

■ Knowledge Base Articles (KBAs): Provide design and application tips from experts on using the 
device. 

■ PSoC Creator Training: Visit www.cypress.com/go/creatorstart/creatortraining for a 
comprehensive list of video training on PSoC Creator.

■ Learning from Peers: Visit community.cypress.com/welcome to meet enthusiastic PSoC develop-
ers discussing the next-generation embedded systems on Cypress Developer Community 
Forums.

1.5 Technical Support

For assistance, visit Cypress Support or contact customer support at +1 (800) 541-4736 Ext. 3 (in
the USA) or +1 (408) 943-2600 Ext. 3 (International).

You can also use the following support resources if you need quick assistance:

■ Self-help (Technical Documents).

■ Local Sales Office Locations.

http://www.cypress.com/
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/psoc
http://www.cypress.com/?rID=86788
http://www.cypress.com/?id=4976
http://www.cypress.com/psoccreator
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4000-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4200-family-datasheet-programmable-system-chip-psoc
www.cypress.com/documentation/datasheets/psoc-4-psoc-4100m-family-datasheet
www.cypress.com/documentation/datasheets/psoc-4-psoc-4200m-family-datasheet
www.cypress.com/documentation/datasheets/psoc-4-psoc-4200l-family-datasheet
www.cypress.com/psoc4100splusdatasheet
http://www.cypress.com/?rID=78578&source=an79953
http://www.cypress.com/search/all?f[0]=meta_type%3Atechnical_documents&f[1]=resource_meta_type%3A574&f[2]=field_related_products%3A1297
http://www.cypress.com/search/all?f[0]=meta_type%3Asoftware_tools&f[1]=field_related_products%3A1297&f[2]=software_tools_meta_type%3A579
http://www.cypress.com/?rID=101641
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=117&id=4749&applicationID=0&l=0
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=110&id=4749&applicationID=0&l=0
http://www.cypress.com/CY8CKIT-041
http://www.cypress.com/CY8CKIT-046
http://www.cypress.com/CY8CKIT-044
http://www.cypress.com/cy8ckit-042
http://www.cypress.com/CY8CKIT-040
http://www.cypress.com/CY8CKIT-043
http://www.cypress.com/CY8CKIT-049
http://www.cypress.com/CY8CKIT-145
www.cypress.com/CY8CKIT-146
www.cypress.com/CY8CKIT-149
http://www.cypress.com/go/CY8CKIT-001
http://www.cypress.com/go/cy8ckit-002
https://community.cypress.com/community/knowledge-base-articles
http://www.cypress.com/go/creatorstart/creatortraining
https://community.cypress.com/welcome
http://www.cypress.com/support
http://www.cypress.com/search/all?f%5b0%5d=meta_type%3Atechnical_documents
http://www.cypress.com/?id=1062
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4700s-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/application-notes/an219207-inductive-sensing-design-guide 
http://www.cypress.com/cy8ckit-005
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1.6 Document Conventions

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes Cautions or unique functionality of the product.
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1.7 Acronyms

Table 1-2.  Acronyms Used in this Document

Acronym Description

BOM Bill of Materials

CE Code Example

CR Circular Coil

DAC Digital to Analog Converter

ESD Electrostatic Discharge

EVK Evaluation Kit

GPIO General Purpose Input/Output

I2C Inter-Integrated Circuit

IDAC Current DAC

IDE Integrated Design Environment

KBA Knowledge Based Article

LE Linear Encoder

LED Light-Emitting Diode

PSoC Programmable Systems-on-Chip

RE Rotary Encoder

SQ Square Coil

SWD Serial Wire Debug

UART Universal Asynchronous Receiver Transmitter

USB Universal Serial Bus
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2. Kit Operation

This chapter introduces you to different features of the Inductive Sensing Coil Breakout Board. This
includes the parameters of each coil on the kit and the recommended configuration settings for use
with the MagSense Component in PSoC Creator.

2.1 Theory of Operation

This section provides a high-level description of the principle of proximity sensing and describes
where the CY8CKIT-148-COIL fits in an inductive sensing system.

2.1.1 Principle of Inductive Sensing

Inductive sensing works on the principle of electromagnetic coupling between a sensor coil and the
metal target to be detected. When the metal target enters the electromagnetic field induced by a
sensor coil, some of the electromagnetic energy is transferred into the metal target as shown in
Figure 2-1. This transferred energy causes a circulating electrical current called an eddy current.
The eddy current flowing in the metal target induces reverse electromagnetic field on the sensor coil,
which results in a reduction of the effective inductance of the sensor coil. 

The sensor coil is placed in parallel with a capacitor. The parallel combination of sensor inductance
and the external capacitor is called a tank circuit. The reduction in the sensor coil inductance causes
an upward shift in the resonant frequency of the tank circuit. This shift in resonant frequency
changes the amplitude of the signal across the sensor coil. The change in the amplitude of the
sensor coil signal is measured by the PSoC 4700S MCU to detect the presence of the metal target in
the proximity-sensing distance. Note that the inductance of the sensor coil increases in the presence
of ferromagnetic metal targets. An increase in the sensor coil inductance causes a down shift in the
resonant frequency of the tank circuit.

Figure 2-1.  Field Coupling between Sensor Coil and Metal Target Inductive Sensing Design Guide
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Typical applications for inductive sensing include the following:

■ Proximity detection

■ Mechanical open/close switches

■ Buttons (industrial keypads and ON/OFF buttons)

■ Rotation detection (flow meters, fan speed RPM detection, rotary control knob)

■ Linear Encoders

■ Spring compression detection

2.1.2 CY8CKIT-148-COIL System

The CY8CKIT-148 provides three buttons and one proximity sensor. By adding the CY8CKIT-148-
COIL, additional coils which may be used as reference designs for custom inductive sensing
systems are added. These sensors can be interfaced with PSoC 4700S device present on the
CY8CKIT-148 PSoC 4700S Inductive Sensing Evaluation Kit. 

Figure 2-2.  Connection between the CY8CKIT-148-COIL kit and the CY8CKIT-148 base board 
using the provided FPC connector 



CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board Kit Guide, Document Number: 002-26890 Rev. ** 20

Kit Operation

The MagSense circuitry in the PSoC 4700S device on the CY8CKIT-148 EVK senses the changes in
the inductance of the coils on the CY8CKIT-148-COIL. Based on the data the PSoC 4700S device
receives, the PSoC MCU determines the presence of a conductive target object.

The PSoC device on the CY8CKIT-148 EVK may be programmed through the on-board KitProg
hardware, which communicates to the software programming tool (PSoC Programmer) through the
USB interface on the board. You can develop firmware applications for the PSoC 4700S to handle
the inductive sensing data using PSoC Creator IDE. 

CE225409 - PSoC 4700S MagSense COIL provides example projects that can be used with the
CY8CKIT-148-COIL to implement custom applications.

2.2 Functional Description

2.2.1 Metal Targets

Figure 2-3.  Metal Targets on the CY8CKIT-148-COIL 

The CY8CKIT-148-COIL kit contains four metal targets, each with a different size or shape. The
metal targets are meant to be broken away from the kit board and moved into the magnetic field of
the desired inductive sensor. 

METAL TARGET 2 as shown in Figure 2-3 is a linear target designed to be moved horizontally
across a sensor. As the target moves horizontally across the sensor, the sensor signal will also
change linearly. 

METAL TARGET 4 (Rotary Target) is a 119° arc circular target. This target can be used with the
rotary encoder sensor to determine rotational position of the metal target over the sensor. 
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2.2.2 Multi-purpose Sensors (CR1-CR5, SQ7, SQ8)

Figure 2-4.  Multi-purpose Sensors (CR1-CR5, SQ7, SQ8)

The CY8CKIT-148-COIL kit contains seven multi-purpose sensors. These sensors may be used for
either proximity detection or button replacement applications.

CR1 and CR2 are 15 mm circular multi-purpose sensors. CR3 and CR4 are 5 mm circular multi-
purpose sensors and CR5 is a 25 mm circular multi-purpose sensor.

SQ7 and SQ8 are 20 mm square multi-purpose sensors. 

Each multi-purpose sensor is capable of detecting conductive targets in close proximity to or in
contact with the sensor. 

2.2.3 Six-Segment Slider (SQ1-SQ6)

Figure 2-5.  Six-Segment Slider

The CY8CKIT-148-COIL kit includes an array of six 10 mm square coils. These coils can be directly
connected to the CY8CKIT-148 EVK using the FPC connector. These coils can detect horizontal
position of a target above each sensor as well as gestures such as a horizontal slide. 
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2.2.4 Linear Encoder (LE1, LE2)

Figure 2-6.  Linear Encoders 

There are two 100 mm × 8 mm linear encoder coils. These coils detect horizontal movement of a
METAL TARGET 2 above the sensors.

2.2.5 Rotary Encoder (RE1, RE2)

Figure 2-7.  Rotary Encoder 

There is a single rotary encoder on the kit. The rotary encoder consists of two 120° arc angle sen-
sors placed adjacent to each other. The strength of the sensor signal acquired by turning METAL
TARGET 4 over the sensors is translated in to rotational angle. For a description of the algorithm
used to detect the rotational angle, see CE225409 - PSoC 4700S MagSense COIL.
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2.3 Sensor Parameters and Recommended Settings

The following table provides the inductance values of each coil on the kit as well as the resonant fre-
quency of each sensor. Recommended MagSense Component configuration settings are provided
as well.

In general, it is good practice to set the Component Lx clock frequency to a value slightly lower to the 
resonant frequency of the sensing tank circuit. In some cases, Lx clock frequency values above the 
center frequency may be used as the circuit has better performance at different frequencies. 

2.4 Code Example
The code example CE225409 – PSoC 4700S MagSense COIL demonstrates how to use each of the
coil types on the CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board with the CY8CKIT-148
Inductive Sensing Evaluation Kit. There are five projects available in this code example:

■ 6-Segment Slider

■ Linear Encoder

■ Linear Target

■ Rotary Encoder

■ Proximity Sensor

Each project is designed for a specific sensor. Refer the code example document for details.

Table 2-1.  Sensor Parameters and Recommended Settings

Sensor Parameters Recommended Component Configuration

Sensor Inductance (µH)
Resonant 
Frequency 
(kHz)

Lx Clock 
Frequency 
(kHz)

IDAC Value Sub-Conversions

LE1, LE2 28.8 653.0 648.65 71 600

RE1, RE2 4.32 522.8 500 11 300

CR1, CR2 22.5 765.3 750 45 600

CR3, CR4 0.89 + 2.2a

a. Additional inductor in series (The on-board components L1 and L2 are in series with the coil traces).

625.1 600 15 500

CR5 113.9 329.0 320 39 300

SQ1-SQ6 7.0 641.0 615.38 26 624

SQ7, SQ8 65.2 437.0 466.02 51 585
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A.1 Board Details

The CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board consists of seven types of sensors.
The functionalities of all the sensors is described in Kit Operation chapter on page 18. You need to
know how these sensors are connected to the on-board FPC connectors or I/O headers. See the
mapping between the notation of individual sensor type to the reference designator and
corresponding on-board header/connector in the Table A-1. 

A.2 Header/Connector Details

The Coil Breakout Board has two FPC connectors and several unpopulated headers to hookup the
sensors with the CY8CKIT-148 kit. See Table A-1 and “Header Connections” on page 25 to know the
pin-mapping between this breakout board and the main CY8CKIT-148 board. 

Table A-1.  Reference designators, notations and headers/connectors of individual sensors

Sl No Coil Notation REF DES Header
FPC 

Connector

1 ROTARY ENCODERS RE1 BTN4 J77 J2

RE2 J70

2 25 MM CIRCULAR CR5 BTN5 J71

3 LINEAR ENCODERS LE1 BTN1 J75

LE2 BTN2 J76

4 5 MM CIRCULAR CR3 BTN7 J53 Sensors not 
connected to 

any FPC 
connector

CR4 BTN16 J68

5 15 MM CIRCULAR CR1 BTN3 J72

CR2 BTN14 J69

6 20 MM SQUARE SQ7 BTN6 J73

SQ8 BTN15 J74

7 6-SEGMENT SLIDERS SQ1, SQ2, SQ3, 
SQ4, SQ5, SQ6

BTN8, BTN9, 
BTN10, BTN11, 
BTN12, BTN13

J1 J3
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A.2.1 Header Connections

In addition to the FPC connector (J3), a 16-pin I/O header (J1) is provided to interface the 6-segment
slider with the coil expansion connector (J4) on the CY8CKIT-148 base board.

Figure A-1.  I/O header connector on the Inductive Sense Breakout board

Figure A-2.  Coil expansion connector on the CY8CKIT-148

Figure A-3.   Coupling capacitors of the RX connections on the CY8CKIT-148 board 

The pins of J4 on CY8CKIT-148 are multiplexed with the pins of the FPC connector (J6). See the kit guide
of CY8CKIT-148 to learn more about the connection details. To interface the sensors through the I/O
headers, remove the capacitors C10, C11, C12, C13, C15, C16, and load the capacitors C52, C53,
C54, C55, C56, C57 on the CY8CKIT-148 board.

https://www.cypress.com/documentation/development-kitsboards/cy8ckit-148-psoc-4700s-inductive-sensing-evaluation-kit
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See Table A-2 for pin mapping of the 16-pin headers (CY8CKIT-148 kit and the coil breakout
board).
If you want to evaluate the sensors connecting through the headers, refer Table A-2 and Figure A-3 
to know the required connection modifications. 

Table A-2.  Pin mapping of the coil expansion connector of the CY8CKIT-148 board and I/O headers 
of the CY8CKIT-148-COIL board

CY8CKIT-148-COIL CY8CKIT-148
Hardware connection 

modification on 
CY8CKIT-148

I/O Header (J1) of Slider (SQ1–SQ6)a

a. The Table A-2 is an example of interfacing the slider (SQ1 to SQ6) of CY8CKIT-148-COIL to PSoC 4700S device on CY8CKIT-148 through
I/O header. If you want to connect any other sensor through header, populate the on-board I/O header as per the Table A-1 and do the
hardware connection modification on CY8CKIT-148 as per Table A-2.

Coil Expansion Connector (J4)

Pin Sensor Trace Coil Name Header pin PSoC 4700S device pin

1 GND N/A 1 GND

2 LX1 SQ1 2 P2.4

3 RX1 SQ1 3 P0.4 Remove C10 and 
populate C52

4 LX2 SQ2 4 P2.5

5 RX2 SQ2 5 P0.5 Remove C11 and 
populate C53

6 LX3 SQ3 6 P2.6

7 RX3 SQ3 7 P0.6 Remove C12 and 
populate C54

8 LX4 SQ4 8 P2.7

9 RX4 SQ4 9 P0.7 Remove C13 and 
populate C55

10 LX5 SQ5 10 P3.4

11 RX5 SQ5 11 P1.2 Remove C15 and 
populate C56

12 LX6 SQ6 12 P3.5

13 RX6 SQ6 13 P1.3 Remove C16 and 
populate C57

14 GND N/A 14 GND

15 GND N/A 15 GND

16 NC N/A 16 VDDD

http://www.cypress.com/cy8ckit-148-coil
http://www.cypress.com/cy8ckit-148
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A.2.2 FPC Connector

There are two FPC Connectors provided on-board and an FPC cable. The FPC connectors and
cable are required for this kit to connect to the CY8CKIT-148 kit. FPC connectors are low noise
connectors which are good for MagSense functionality.

Figure A-4.  On board FPC connectors 

See Table A-3 to know the PSoC 4700S pin connections to the header mapping between the
CY8CKIT-148 kit and the coil breakout board. 

Table A-3.  Pin mapping of the FPC connectors (CY8CKIT-148 kit and the coil breakout board)

CY8CKIT-148-COIL CY8CKIT-148

FPC connector 1 (J3) FPC connector 2 (J2) FPC connector (J6)

Pin
Sensor 
Trace

Coil Name pin Sensor Trace Coil Name
Connector 

pin
PSoC 4700S 
device pin

1 LX1 SQ1 1 LX15 LE1 1 P2.4

2 LX2 SQ2 2 LX16 LE2 2 P2.5

3 LX3 SQ3 3 LX11 RE2 3 P2.6

4 LX4 SQ4 4 LX12 CR5 4 P2.7

5 LX5 SQ5 5 LX17 RE1 5 P3.4

6 LX6 SQ6 6 NC N/A 6 P3.5

7 GND N/A 7 GND N/A 7 GND

8 GND N/A 8 GND N/A 8 GND

9 GND N/A 9 GND N/A 9 GND

10 GND N/A 10 GND N/A 10 GND

11 RX1 SQ1 11 NC N/A 11 P0.4

12 RX2 SQ2 12 RX15 LE1 12 P0.5

13 RX3 SQ3 13 RX16 LE2 13 P0.6

14 RX4 SQ4 14 RX11 RE2 14 P0.7

15 RX5 SQ5 15 RX12 CR5 15 P1.2

16 RX6 SQ6 16 RX17 RE1 16 P1.2
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A.3 CY8CKIT-148-COIL Inductive Sensing Coil Breakout Board 
Schematics and the Bill of Materials

The schematic and the BoM of the CY8CKIT-148-COIL board is available at the kit webpage.

www.cypress.com/cy8ckit-148-coil
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